[oi-dev] OI 'hipster' reboot effort

Andrzej Szeszo aszeszo at gmail.com
Tue Jun 4 10:01:05 UTC 2013


You probably have package dependent on SUNWperl584core installed on
your system. Sun Studio perhaps?

setuptools-26 issue is something I have not seen yet...

Andrzej

On 4 June 2013 11:38, Udo Grabowski (IMK) <udo.grabowski at kit.edu> wrote:
> On 28/05/2013 23:18, Udo Grabowski (IMK) wrote:
>>
>> On 28/05/2013 15:32, Udo Grabowski (IMK) wrote:
>>>
>>> On 24/05/2013 00:57, Andrzej Szeszo wrote:
>>>>
>>>> Hi Udo
>>>>
>>>> I was aware of the conflicts. I have just pushed some obsoleting
>>>> packages to the git repo and they will appear in the package repo in
>>>> ~5 minutes.
>>>>
>>>> They should take number of non-installable packages down to 8:
>>>>
>>> ....
>>>
>>> Not quite there yet (but close),
>
>
> Minor nits: After the last update a few days go, perl-584 and
> setuptools-26 (python-2.6) are still shown as updates, but do
> not so (probably because of 'Latest version not available
> from this publisher', and renamed perl-584 package):
>
> packagemanager update via version information panel
> Error:
> No solution was found to satisfy constraints
>
> maintained incorporations:
>
>
> pkg://openindiana.org/consolidation/gfx/[email protected],5.11-0.151.1.8:20130305T142155Z
>
> pkg://openindiana.org/consolidation/man/[email protected],5.11-0.151.1.8:20130305T142156Z
>
> pkg://openindiana.org/consolidation/admin/[email protected],5.11-0.151.1.8:20130305T142156Z
>
> pkg://openindiana.org/consolidation/SunVTS/[email protected],5.11-0.151.1.8:20130305T142156Z
>
> pkg://openindiana.org/consolidation/ub_javavm/[email protected],5.11-0.151.1.8:20130305T143751Z
>
> pkg://openindiana.org/consolidation/solaris_re/[email protected],5.11-0.151.1.8:20130305T142156Z
>
> pkg://openindiana.org/consolidation/cacao/[email protected],5.11-0.151.1.8:20130305T142156Z
>
> pkg://openindiana.org/consolidation/jdmk/[email protected],5.11-0.151.1.8:20130305T142156Z
>
> pkg://openindiana.org/consolidation/dbtg/[email protected],5.11-0.151.1.8:20130305T143739Z
>
> pkg://openindiana.org/consolidation/ips/[email protected],5.11-0.151.1.8:20130305T143741Z
>
> pkg://openindiana.org/text/groff/[email protected],5.11-0.151.1.8:20130407T134404Z
>
> pkg://openindiana.org/consolidation/cde/[email protected],5.11-0.151.1.8:20130305T142156Z
>
> pkg://openindiana.org/consolidation/osnet/[email protected],5.11-0.151.1.8:20130305T143746Z
>
> pkg://openindiana.org/consolidation/vpanels/[email protected],5.11-0.151.1.8:20130305T143753Z
>
> pkg://openindiana.org/consolidation/l10n/[email protected],5.11-0.151.1.8:20130305T143742Z
>
> pkg://openindiana.org/consolidation/X/[email protected],5.11-0.151.1.8:20130305T143755Z
>
> pkg://openindiana.org/consolidation/sic_team/[email protected],5.11-0.151.1.8:20130305T143750Z
>
> pkg://openindiana.org/consolidation/sunpro/[email protected],5.11-0.151.1.8:20130305T142156Z
>
> pkg://openindiana.org/consolidation/cns/[email protected],5.11-0.151.1.8:20130305T142156Z
>
> pkg://openindiana.org/consolidation/nspg/[email protected],5.11-0.151.1.8:20130305T142156Z
>
> pkg://openindiana.org/consolidation/install/[email protected],5.11-0.151.1.8:20130305T143740Z
>
> pkg://openindiana.org/consolidation/hcts/[email protected],5.11-0.151.1.8:20130305T142156Z
>
> pkg://openindiana.org/consolidation/xvm/[email protected],5.11-0.151.1.8:20130305T142156Z
>
> Plan Creation: Errors in installed packages due to proposed changes:
>
>   No suitable version of installed package
> pkg://openindiana.org/[email protected],5.11-0.133:20100914T033713Z
> found
>     Reject:
> pkg://openindiana.org/[email protected],5.11-0.133:20100914T033713Z
>     Reason:  All acceptable versions of 'require' dependency on
> pkg:/runtime/perl-584 at 5.8.4,5.11-0.133 are obsolete
>   No suitable version of installed package
> pkg://opensolaris.org/developer/[email protected],5.11-0.111:20100306T002245Z
> found
>     Reject:
> pkg://opensolaris.org/developer/[email protected],5.11-0.111:20100306T002245Z
>     Reason:  All versions matching 'require' dependency
> pkg:/SUNWperl584core at 5.8.4,5.11-0.111 are rejected
>       Reject:
> pkg://openindiana.org/[email protected],5.11-0.133:20100914T033713Z
>       Reason:  All acceptable versions of 'require' dependency on
> pkg:/runtime/perl-584 at 5.8.4,5.11-0.133 are obsolete
>       Reject:
> pkg://opensolaris.org/[email protected],5.11-0.111:20090331T085645Z
>
> pkg://opensolaris.org/[email protected],5.11-0.111:20090418T193920Z
>
> pkg://opensolaris.org/[email protected],5.11-0.111:20090508T162639Z
>
> pkg://opensolaris.org/[email protected],5.11-0.116:20090616T195704Z
>
> pkg://opensolaris.org/[email protected],5.11-0.117:20090623T142712Z
>
> pkg://opensolaris.org/[email protected],5.11-0.118:20090707T223331Z
>
> pkg://opensolaris.org/[email protected],5.11-0.121:20090816T231122Z
>
> pkg://opensolaris.org/[email protected],5.11-0.122:20090828T212923Z
>
> pkg://opensolaris.org/[email protected],5.11-0.123:20090911T211201Z
>
> pkg://opensolaris.org/[email protected],5.11-0.124:20090925T215519Z
>
> pkg://opensolaris.org/[email protected],5.11-0.125:20091013T074624Z
>
> pkg://opensolaris.org/[email protected],5.11-0.126:20091022T211727Z
>
> pkg://opensolaris.org/[email protected],5.11-0.127:20091111T102636Z
>
> pkg://opensolaris.org/[email protected],5.11-0.128:20091125T034700Z
>
> pkg://opensolaris.org/[email protected],5.11-0.129:20091205T114857Z
>
> pkg://opensolaris.org/[email protected],5.11-0.130:20091219T024923Z
>
> pkg://opensolaris.org/[email protected],5.11-0.131:20100115T030152Z
>
> pkg://opensolaris.org/[email protected],5.11-0.132:20100130T104703Z
>
> pkg://opensolaris.org/[email protected],5.11-0.133:20100216T091233Z
>       Reason:  Currently installed package 'SUNWperl584core' is from sticky
> publisher 'openindiana.org'.
>                Newer version
> pkg://openindiana.org/[email protected],5.11-0.133:20100914T033713Z is
> already installed
>
> packagemanager update via version information panel:
> Preparing...
> Gathering package information
>
> Error:
> No matching version of library/python-2/setuptools-26 can be installed:
>   Reject:
> pkg://openindiana.org/library/python-2/[email protected],5.11-0.151.1.8:20130305T144619Z
>   Reason:  A version for 'require' dependency on
> pkg:/library/python-2/setuptools at 0.6.11,5.11-0.151.1.8 cannot be found
>
>
>
> --
> Dr.Udo Grabowski    Inst.f.Meteorology a.Climate Research IMK-ASF-SAT
> www.imk-asf.kit.edu/english/sat.php
> KIT - Karlsruhe Institute of Technology            http://www.kit.edu
> Postfach 3640,76021 Karlsruhe,Germany  T:(+49)721 608-26026 F:-926026
>
>
> _______________________________________________
> oi-dev mailing list
> oi-dev at openindiana.org
> http://openindiana.org/mailman/listinfo/oi-dev




More information about the oi-dev mailing list