[OpenIndiana-discuss] OI boot problem

GUY WOOLLEY guy.woolley at btinternet.com
Sat Mar 26 17:59:44 UTC 2011

Thanks - I've tried what you suggest but as noted above "reboot" just leads to the black screen with GRUB_.

In the scenario of my previous post, if I do
pfexec bootadm update-archive -R /a/b

I get

bootadm: missing /boot/grub on root: /a/b

and I don't know how to fix that.


--- On Sat, 26/3/11, Apostolos Syropoulos <asyropoulos at yahoo.com> wrote:

From: Apostolos Syropoulos <asyropoulos at yahoo.com>
Subject: Re: [OpenIndiana-discuss] OI boot problem
To: "Discussion list for OpenIndiana" <openindiana-discuss at openindiana.org>
Date: Saturday, 26 March, 2011, 17:37

> jack at opensolaris:~$ pfexec zfs mount rpool/ROOT/0i_148-2
> jack at opensolaris:~$ cd /a/b


If Oi_148-2 is a boot environment (BE), I just wonder why you don't
use /usr/sbib/beadm to mount this BE? I have also tried to mount
using zfs mount and in the end the file system became useless.


Apostolos Syropoulos
Xanthi, Greece


OpenIndiana-discuss mailing list
OpenIndiana-discuss at openindiana.org

More information about the OpenIndiana-discuss mailing list