[OpenIndiana-discuss] 4k zpool version no longer available?

Jaco Schoonen jaco at macuser.nl
Mon Sep 24 22:16:47 UTC 2012

Hi Richard,

Thanks for your quick reply!

>> After studying all the information about 4K-disks I figured out that to get more space in my server I need to create a new pool, consisting of 4K-disks and then moving everything from the old 512-byte pool to the new one. 
>> So far, so good. Everything is connected and detected correctly.  The 3TB Seagate drives that I bought unfortunately lie about their physical sector size, so I wanted to try the modified zpool as suggested in the wiki-page http://wiki.openindiana.org/pages/viewpage.action?pageId=4883847 . 
> A fix has been implemented upstream. See the details at 
> https://www.illumos.org/issues/2665

Reading there that this is included in illumos changeset 13680 and reading in release_notes of 151_a5 that oi151_a5 is based on 13740. Is my assumptions correct that this should work in oi151_a5?

> NB, VID/PID is matched by length, so "SEAGATE ST" will match all Seagate drives with
> product ID starting with "ST"
> 	sd-config-list = "SEAGATE ST", "physical-block-size:4096";

Just tried that, but can't get it to work. Do I need to reboot before this will work? 

I tried after doing a "update_drv -f sd", but that gave an error:
# update_drv -f sd
Cannot unload module: sd
Will be unloaded upon reboot.
Forcing update of sd.conf.

Will try tomorrow after a reboot, can't do a reboot right now.


More information about the OpenIndiana-discuss mailing list