[OpenIndiana-discuss] /hipster OS update fails because of EFI support from Illumos

Predrag Zecevic [Unix Systems Administrator] Predrag.Zecevic at 2e-systems.com
Mon Mar 9 08:17:56 UTC 2015

Hi all,

currently, I am running /hipster-2015:
$ pkg publisher openindiana.org

             Publisher: openindiana.org
            Origin URI: http://pkg.openindiana.org/hipster-2015/
               SSL Key: None
              SSL Cert: None
           Client UUID: 08bfde0c-5000-fd2f-f84e-040800000000
       Catalog Updated: March  8, 2015 05:50:53 PM
               Enabled: Yes

$ uname -rosv
SunOS 5.11 illumos-da5086c Solaris

and tried to upgrade OS this morning:

$ pkg_update oi151_hipster2015_0309
             Packages to update:       418
      Estimated space available: 109.73 GB
Estimated space to be consumed: 840.52 MB
        Create boot environment:       Yes
      Activate boot environment:       Yes
Create backup boot environment:        No
           Rebuild boot archive:       Yes

Changed packages:
     0.5.11-2015.0.0.14921:20150226T134319Z -> 0.5.11-2015.0.0.14937:20150307T131746Z
DOWNLOAD                                PKGS         FILES    XFER (MB)   SPEED
Completed                            418/418     4209/4209  125.3/125.3  3.0M/s

PHASE                                          ITEMS
Removing old actions                       1102/1102
Installing new actions                       982/982
Updating modified actions                  9044/9044
Updating package state database                 Done
Updating package cache                       418/418
Updating image state                            Done
Creating fast lookup database                   Done
Reading search index                            Done
Building new search index                  1699/1699
pkg: unable to activate oi151_hipster2015_0309

NOTE: Please review release notes posted at:


Activation of BE failed, and I tried again:

$ pfexec beadm activate -v oi151_hipster2015_0309
be_do_installgrub: installgrub failed for device c3d0s0.
   Command: "/sbin/installgrub  /export/tmp/tmp6DTXaC/boot/grub/stage1 /export/tmp/tmp6DTXaC/boot/grub/stage2 /dev/rdsk/c3d0s0"
Booting of EFI labeled disks is only supported with ZFS
Unable to gather device information for /dev/rdsk/c3d0s0
be_run_cmd: command terminated with error status: 1
Unable to activate oi151_hipster2015_0309.
Error installing boot files.

$ beadm list
beadm list
BE                     Active Mountpoint            Space Policy Created
oi151_hipster2015_0227 NR     /                     25.9G static 2015-02-27 06:58
oi151_hipster2015_0309 -      /export/tmp/tmp6DTXaC 751M  static 2015-03-09 08:44

$ fstyp /dev/rdsk/c3d0s0

Now what? (I definitely do *not* use EFI, because my hardware is 8 years OLD and disks use IDE. So, was able to upgrade systems all 
way from OpenSolaris until recent changes have been made to Illumos).

http://wiki.openindiana.org offers no info/solution, adn I have found this, but it doesn't fit to my scenario:
* http://comments.gmane.org/gmane.os.illumos.devel/20580 (doesn't offer solution)
* http://www.listbox.com/member/archive/post_content.html?post_id=20150223110327:7E614B22-BB75-11E4-9A6E-AF45EBF176B7&address=000 
(also no solution)


P.S. apologies for spam in advance if I missed somebody's tip or post
Predrag Zečević
Technical Support Analyst
2e Systems GmbH

Telephone: +49 6196 9505 815, Facsimile: +49 6196 9505 894
Mobile:    +49  174 3109 288,     Skype: predrag.zecevic
E-mail:    predrag.zecevic at 2e-systems.com

Headquarter:          2e Systems GmbH, Königsteiner Str. 87,
                       65812 Bad Soden am Taunus, Germany
Company registration: Amtsgericht Königstein (Germany), HRB 7303
Managing director:    Phil Douglas

http://www.2e-systems.com/ - Making your business fly!

More information about the openindiana-discuss mailing list