[OpenIndiana-discuss] Hipster upgrade 18-feb-2015

Jonathan Adams t12nslookup at gmail.com
Thu Mar 26 12:38:05 UTC 2015

I got fed up one evening, and then I remembered working with Intel on my
old Solaris 10 desktop, and needing to set the resolution with
"915resolution" ...

I went back to my old files and found it, downloaded the "newer" version
from 2007, made some changes to it and got a working 915resolution for
Illumos that allows the modes to be set.

I then de-installed the intel driver from hipster, set the resolution and
have vesa working at 1280x800.

obviously not the perfect answer, but since the hardware acceleration on
the old intel driver (on the old intel card) wasn't the best, I have a
working, updated version of OI on my laptop, with no sticky's.


On 20 February 2015 at 09:14, Nikola M <minikola at gmail.com> wrote:

> On 02/18/15 05:03 PM, Jonathan Adams wrote:
>> root at jadlaptop:~# pkg list -af | grep xorg-video-intel
>> x11/server/xorg/driver/xorg-video-intel (openindiana.org)
>> 2.99.917-2015.0.0.0        ---
>> x11/server/xorg/driver/xorg-video-intel (openindiana.org)
>> 2.18.0-2015.0.0.0          ---
>> x11/server/xorg/driver/xorg-video-intel (openindiana.org)
>> 2.18.0-2015.0.0.0          ---
>> x11/server/xorg/driver/xorg-video-intel (openindiana.org)
>> 2.9.1-2015.0.0.0           ---
>> x11/server/xorg/driver/xorg-video-intel (openindiana.org)
>> 2.6.3-2015.0.0.1           ---
>> x11/server/xorg/driver/xorg-video-intel (openindiana.org)
>> 2.6.3-2014.1.3.0           i--
>> hmm ... I do appear to be stuck at an old version of the intel driver ...
>>  Same (1024X768 fixed screen resolution) happens with intel 945 graphics,
> that worked OK till 2015.
> I think it also worked in 2015 before last update.
> Only, Hipster does not update 'entire' package on every update, so I can
> not update from 20141010 to 2015 prior to latest update of 2015. (destroyed
> it before another 2015 update). So 2015 is not usable currently for desktop.
> Also , managing screen brightness from GNOME applet fails in today's
> hipster-2015 , this is second blow to Hipster Laptop use since standby
> stopped working in Spring 2014 (also destroyed old Hipster BE where it last
> worked so can not go back to it to see what changed)
> When updating, even when /opt is cleaned and mounted and work like that
> right after that in 2014.1 (separate issuue on freezing display on logging
> as another user - I should report user's settings maybe),
> after update to 2015 it needs also cleaning /opt and rebooting again to
> boot right.
> Obviously update mess with installing something in /opt under
> /opt/install-test
> and leaves dirs of sub-datasets in there. (That is problem from before
> 20141010)
> It is suggested it is illumos problem and to cry there for leaving /opt in
> piece... Let's cry.
> _______________________________________________
> openindiana-discuss mailing list
> openindiana-discuss at openindiana.org
> http://openindiana.org/mailman/listinfo/openindiana-discuss

More information about the openindiana-discuss mailing list