[oi-dev] new (minor) dependency issue in hipster repo

Chad Cantwell chad at iomail.org
Thu Jun 20 01:36:06 UTC 2013


In a new install of 151a7, just upgraded to hipster 151a8, I'm having an issue with the netcat package:

# pkg install netcat
Creating Plan |
pkg install: The requested change to the system attempts to install multiple actions
for legacy 'SUNWftpr' with conflicting attributes:

    1 package delivers 'legacy category=system desc="FTP Server Configuration Files" hotline="Please contact your local service provider" name="FTP Server, (Root)" pkg=SUNWftpr vendor="Project OpenIndiana" version=11.11,REV=2009.11.11':
        pkg://openindiana.org/service/network/[email protected],5.11-0.151.1.8:20130305T144949Z
    1 package delivers 'legacy category=system desc="FTP Server Configuration Files" hotline="Please contact your local service provider" name="FTP Server, (Root)" pkg=SUNWftpr vendor=Illumos version=11.11,REV=2009.11.11':
        pkg://openindiana.org/[email protected],5.11-0.151.1.8.1:20130619T222328Z

These packages may not be installed together.  Any non-conflicting set may
be, or the packages must be corrected before they can be installed.

After removing pkg://openindiana.org/service/network/ftp, which I didn't need, I was able to proceed.
It had 50 MB of updates though, so it was probably doing a larger update and had a dependency issue
not directly related to netcat.

Anyway, very minor issue, but I thought someone would want to fix it.




More information about the oi-dev mailing list