[oi-dev] new (minor) dependency issue in hipster repo

Chad Cantwell chad at iomail.org
Sat Jun 22 01:58:57 UTC 2013


On the machines I've experienced this on, one was a plain 151a7 installation with no
new repositories except hipster.  The second machine I tried it on had sfe, sfe-encumbered,
and hipster added, but not much installed from sfe and sfe-encumbered.  Since it also
happened on the first machine without the sfe reposities, I don't think they are relevant.

I've since upgraded all the affected machines to (currently) illumos-bb6e707 from the hipster
repo, and there currently is no issue removing and installing netcat.  Is it possible that
the hipster repo is not necessarily guaranteed to install any arbitrary individual package
correctly if the whole system is not at the newest hipster version?  Since, either the
problem has been fixed, or else the problem exists still but only affects machines not
upgraded all the way before making certain package changes.  It's not a big deal, in any
case, for it to have issues on unupgraded machines if the hipster repo is generally used
for keeping machines more up to date.

Chad

On Fri, Jun 21, 2013 at 08:54:22AM +0100, Andrzej Szeszo wrote:
> Have you got packages from publishers other than openindiana.org installed?
> 
> Can you provide output of the command below?
> 
> pkg list | grep -v -- i--
> 
> Cheers,
> 
> Andrzej
> 
> 
> On 21 June 2013 00:50, Chad Cantwell <chad at iomail.org> wrote:
> > Yes, I noticed a commit about an issue with the hipster repo that was said to be fixed
> > before I ran across the issue.  Anyway, I just checked another machine (since I don't
> > want to reboot the first machine into the older BE), and it has the same error I run
> > 'pkg uninstall netcat' and then 'pkg install netcat'.  Uninstall completes
> > uneventfully but then it can't reinstall:
> >
> > Creating Plan -
> > pkg install: The requested change to the system attempts to install multiple actions
> > for legacy 'SUNWftpr' with conflicting attributes:
> >
> >     1 package delivers 'legacy category=system desc="FTP Server Configuration Files" hotline="Please contact your local service provider" na     me="FTP Server, (Root)" pkg=SUNWftpr vendor="Project OpenIndiana" version=11.11,REV=2009.11.11':
> >         pkg://openindiana.org/service/network/[email protected],5.11-0.151.1.8:20130305T144949Z
> >     1 package delivers 'legacy category=system desc="FTP Server Configuration Files" hotline="Please contact your local service provider" na     me="FTP Server, (Root)" pkg=SUNWftpr vendor=Illumos version=11.11,REV=2009.11.11':
> >         pkg://openindiana.org/[email protected],5.11-0.151.1.8.1:20130619T222328Z
> >
> > These packages may not be installed together.  Any non-conflicting set may
> > be, or the packages must be corrected before they can be installed.
> >
> >
> > Chad
> >
> >
> > On Thu, Jun 20, 2013 at 09:44:50AM +0100, Andrzej Szeszo wrote:
> >> There was a short period when /hipster repo was broken a little bit.
> >> Are you still having the same problem?
> >>
> >> Andrzej
> >>
> >> _______________________________________________
> >> oi-dev mailing list
> >> oi-dev at openindiana.org
> >> http://openindiana.org/mailman/listinfo/oi-dev
> >
> > _______________________________________________
> > oi-dev mailing list
> > oi-dev at openindiana.org
> > http://openindiana.org/mailman/listinfo/oi-dev
> 
> _______________________________________________
> oi-dev mailing list
> oi-dev at openindiana.org
> http://openindiana.org/mailman/listinfo/oi-dev




More information about the oi-dev mailing list