[OpenIndiana-discuss] livecd zpool import -fR /a xpool but no files

Calum Mackay calum.mackay at cdmnet.org
Mon Nov 29 00:54:31 UTC 2010


I'm not sure what happened in your case, but I've just tried it with a 
fresh OI b147 install, and it worked perfectly. At no point did I see 

I installed OIb147 in a Vbox VM, using the DVD ISO.

Then booted the DVD ISO again, and "zpool import" showed me rpool, as 


	zpool import -f -R /a rpool

	zfs set mountpoint=/b rpool/ROOT/openindiana

	zfs mount rpool/ROOT/openindiana

	cat /a/b/etc/passwd

and I could see my personal username in the passwd file, ensuring I was 
looking at my installed /etc.


	zpool export rpool

and reboot, and it came up perfectly into my install, no issues at all.

So this is clearly a usable recovery method, once the mountpoint and 
mount are done. And perhaps there is a better way to handle that, but it 
worked for me.

To address your current situation, I would try booting the ISO/Live 
again, and seeing what "zpool import" says. If it's xpool, or anything 
other than rpool, then:

	zpool import -f -R /a badpool rpool

[where "badpool" is whatever was reported by "zpool import"]

to rename it to rpool, then try the above steps, or just export and reboot.

Hopefully that will get you back going again...


Calum Mackay
Oracle Corporation

More information about the OpenIndiana-discuss mailing list