[OpenIndiana-discuss] samba keeps dumping core on oi_147

Christopher Chan christopher.chan at bradbury.edu.hk
Wed Oct 27 03:25:11 UTC 2010

On Wednesday, October 27, 2010 11:15 AM, Mike Gerdts wrote:
> On Tue, Oct 26, 2010 at 9:43 PM, Albert Lee<trisk at opensolaris.org>  wrote:
>> On Mon, Oct 25, 2010 at 11:53 PM, Christopher Chan
>> <christopher.chan at bradbury.edu.hk>  wrote:
>>> So I ran truss on the master smbd process...
>>> It appears that something fired a SIGTERM arrow at it and then tried to
>>> cancel it with a SIGCONT arrow or something?
>> Not sure about the cause of the crash, but the truss output appears to
>> be Samba trying to perform an orderly shutdown after it gets the first
>> SIGTERM from the SMF stop method.
> This is likely a result of SMF detecting that something in the service
> is sick (dumped core) and as such is performing a restart.  The
> default configuration of the apache22 service is smart enough to
> delegate this work to httpd, which already knows how to deal with
> children that core dump.  From
> /lib/svc/manifest/network/http-apache22.xml:
>                  <property_group name='startd' type='framework'>
>                          <!-- sub-process core dumps shouldn't restart
>                                  session -->
>                          <propval name='ignore_error' type='astring'
>                                  value='core,signal' />
>                  </property_group>
> Perhaps the samba smf service requires a similar configuration.

Ah, so that's where I can tell SMF to leave things alone. I concur. 
Running smbd unmanaged has resulted in zero samba downtime. As for the 
core dumps...

In the logs: smbd[22213] setid process, core not dumped:

      global core file pattern: /var/cores/%d/%f.%p.%n
      global core file content: all
        init core file pattern: core
        init core file content: default
             global core dumps: enabled
        per-process core dumps: enabled
       global setid core dumps: enabled
  per-process setid core dumps: enabled
      global core dump logging: enabled

What am I missing?

More information about the OpenIndiana-discuss mailing list