[OpenIndiana-discuss] Upgrade from b134: few packages get updated

Alex Viskovatoff viskovatoff at imap.cc
Thu Sep 16 14:50:57 UTC 2010

Yes, I uninstalled entire. After I ran into this problem, I also went
back to snv_133, upgraded to snv_134, and tried to upgrade the new
snv_134 boot environment to OI, running into the same problem.

I have a second box with OpenSolaris on it which I use much less. With
that one, I don't run into this problem, but the problem other people
have mentioned: not being able to resolve a host while upgrading
Firefox. (I removed Thunderbird.)

In a comment on the Wiki page about installing and upgrading OI (which
is currently unavailable), someone else reports running into my problem.

I guess a thing to do would be to compare the lists of installed
packages on my two OpenSolaris systems, and to remove all the packages
that are on the system with the problem but not on the one without it,
and see if the problem goes away. But I would prefer if someone who is
more familiar with pkg could tell me how I could get pkg to generate
some information which would tell me why pkg is deciding not to update
most packages while doing an upgrade.


On Thu, 2010-09-16 at 14:56 +0200, Attila Fülöp wrote:
> Alex Viskovatoff wrote:
> > I followed the instructions on the Wiki and the upgrade succeeded, but
> > only 42 packages got upgraded. 
> Did you `pfexec pkg uninstall entire`? Although counterintuitive it is needed
> to resolve the issue you are seeing.
> Attila

More information about the OpenIndiana-discuss mailing list