[OpenIndiana-discuss] Upgrade from b134: few packages get updated

Ron Dawson ron.dawson at gmail.com
Thu Sep 16 16:13:19 UTC 2010

Yes, I have been observing this same problem as well.   I was only getting a
very small subset of OI to update after doing the 'uninstall entire'
(essentially just some Gnome/locale stuff).  I also went back to 133, moved
it up to 134 and that didn't work (same problem).  I'd only get 36
packages/54 MBytes.

Finally late yesterday evening I went back to OS 132, moved it up to OS 134,
and then tried to move that up to OI 147.  That appeared to be working much
better (it was pulling down a much larger package list) but it eventually
crashed pulling down a firefox component.  I'm not sure if that is related
to the thunderbird problem others have reported of it was just server
issues.  Will have to try again.

- Ron

On Thu, Sep 16, 2010 at 2:50 PM, Alex Viskovatoff <viskovatoff at imap.cc>wrote:

> Yes, I uninstalled entire. After I ran into this problem, I also went
> back to snv_133, upgraded to snv_134, and tried to upgrade the new
> snv_134 boot environment to OI, running into the same problem.
> I have a second box with OpenSolaris on it which I use much less. With
> that one, I don't run into this problem, but the problem other people
> have mentioned: not being able to resolve a host while upgrading
> Firefox. (I removed Thunderbird.)
> In a comment on the Wiki page about installing and upgrading OI (which
> is currently unavailable), someone else reports running into my problem.
> I guess a thing to do would be to compare the lists of installed
> packages on my two OpenSolaris systems, and to remove all the packages
> that are on the system with the problem but not on the one without it,
> and see if the problem goes away. But I would prefer if someone who is
> more familiar with pkg could tell me how I could get pkg to generate
> some information which would tell me why pkg is deciding not to update
> most packages while doing an upgrade.
> Alex
> On Thu, 2010-09-16 at 14:56 +0200, Attila Fülöp wrote:
> > Alex Viskovatoff wrote:
> > > I followed the instructions on the Wiki and the upgrade succeeded, but
> > > only 42 packages got upgraded.
> >
> > Did you `pfexec pkg uninstall entire`? Although counterintuitive it is
> needed
> > to resolve the issue you are seeing.
> >
> >
> > Attila
> _______________________________________________
> OpenIndiana-discuss mailing list
> OpenIndiana-discuss at openindiana.org
> http://openindiana.org/mailman/listinfo/openindiana-discuss

More information about the OpenIndiana-discuss mailing list