[OpenIndiana-discuss] SFTP fails within jedit in OpenIndiana

Ewald Ertl ewald.ertl at gmail.com
Tue Sep 21 11:20:39 UTC 2010

Hello Onno,

On Tue, Sep 21, 2010 at 11:57 AM, Onno Molenkamp <onno at flox.org> wrote:

> Ewald Ertl schreef op 21-09-10 09:00:
> > The problem seems to be the line:
> > 8:39:59 AM [jEdit I/O #3] [message] SftpLogger: ssh_rsa_verify: signature
> > false
> >
> > Because a verbose sftp says:
> > debug1: ssh_rsa_verify: signature correct
> What happens if you remove sun.security.pkcs11.SunPKCS11 from the list
> of security providers in /usr/jdk/latest/jre/lib/security/java.security
> and try again? (you will have to renumber the list to make sure it still
> starts at 1)

I don't know whats happening behind the scenes by removing the security
provider, but the SFTP
connect from jedit works now. Also ssh/sftp/scp still work.

The question still is, if it's somewhere a problem in OpenIndiana, because
the same thing worked in
Build 134 without removing the security provider.

Thank you for your help, to get the SFTP in jedit to work.


> Onno
> _______________________________________________
> OpenIndiana-discuss mailing list
> OpenIndiana-discuss at openindiana.org
> http://openindiana.org/mailman/listinfo/openindiana-discuss

More information about the OpenIndiana-discuss mailing list