[OpenIndiana-discuss] SFTP fails within jedit in OpenIndiana

Albert Lee trisk at opensolaris.org
Sun Sep 26 18:05:42 UTC 2010

On Tue, Sep 21, 2010 at 7:37 AM, Onno Molenkamp <onno at flox.org> wrote:
> Ewald Ertl schreef op 21-09-10 13:20:
>> I don't know whats happening behind the scenes by removing the security
>> provider, but the SFTP
>> connect from jedit works now. Also ssh/sftp/scp still work.
>> The question still is, if it's somewhere a problem in OpenIndiana, because
>> the same thing worked in
>> Build 134 without removing the security provider.
> The Java SunPKCS11 provider is a Solaris-specific provider that uses the
> pkcs11 stuff in Solaris to do cryptography more efficiently, but because
> of a bug introduced in build 142 of OS/Net, it doesn't work (properly)
> anymore.
> The problem is supposed to be fixed in build 150, which unfortunately
> isn't publicly available.
> Onno

This is probably the root cause of https://www.illumos.org/issues/255
, I'm updating that bug to check.


More information about the OpenIndiana-discuss mailing list