[OpenIndiana-discuss] Problem with high cpu load (oi_151a)

Ken Gunderson kgunders at teamcool.net
Thu Oct 20 16:52:05 UTC 2011

On Thu, 2011-10-20 at 18:44 +0200, Gernot Wolf wrote:
> Hello all,
> I have a machine here at my home running OpenIndiana oi_151a, which 
> serves as a NAS on my home network. The original install was OpenSolaris 
> 2009.6 which was later upgraded to snv_134b, and recently to oi_151a.
> So far this OSOL (now OI) box has performed excellently, with one major 
> exception: Sometimes, after a reboot, the cpu load was about 50-60%, 
> although the system was doing nothing. Until recently, another reboot 
> solved the issue.
> This does not work any longer. The system has always a cpu load of 
> 50-60% when idle (and higher of course when there is actually some work 
> to do).
> I've already googled the symptoms. This didn't turn up very much useful 
> info, and the few things I found didn't apply to my problem. Most 
> noticably was this problem which could be solved by disabling cpupm in 
> /etc/power.conf, but trying that didn't show any effect on my system.
> So I'm finally out of my depth. I have to admit that my knowledge of 
> Unix is superficial at best, so I decided to try looking for help here.
> I've run several diagnostic commands like top, powertop, lockstat etc. 
> and attached the results to this email (I've zipped the results of kstat 
> because they were >1MB).
> One important thing is that when I boot into the oi_151a live dvd 
> instead of booting into the installed system, I also get the high cpu 
> load. I mention this because I have installed several things on my OI 
> box like vsftpd, svn, netstat etc. I first thought that this problem 
> might be caused by some of this extra stuff, but getting the same system 
> when booting the live dvd ruled that out (I think).
> The machine is a custom build medium tower:
> S-775 Intel DG965WHMKR ATX mainbord
> Intel Core 2 Duo E4300 CPU 1.8GHz
> 1x IDE DVD recorder
> 1x IDE HD 200GB (serves as system drive)
> 6x SATA II 1.5TB HD (configured as zfs raidz2 array)
> I have to solve this problem. Although the system runs fine and 
> absolutely serves it's purpose, having the cpu at 50-60% load constantly 
> is a waste of energy and surely a rather unhealthy stress on the hardware.
> Anyone any ideas...?

One.  But I haven't even made cursory scan of your logs. Nor do I know
if it is problem any longer but I used to see similar with bge driver.
Worked great on OS 2009.06 but subsequent stuff horked it up somehow.
My solution was to use the other nvidia based interface.  I think there
is/was a bug file on Illumos Redmine?  Others will surely know more but
quick test you can do is to try a different network driver and see if
the problem goes away.

hth-- Ken

Regards-- Ken Gunderson

More information about the OpenIndiana-discuss mailing list