[OpenIndiana-discuss] ZFS, Samba, Windows ACLs

lbragg at me.com lbragg at me.com
Tue Oct 16 02:44:58 UTC 2012

Date: Sat, 13 Oct 2012 19:01:43 +0400
From: Jim Klimov <jimklimov at cos.ru>
To: Discussion list for OpenIndiana
<openindiana-discuss at openindiana.org>
Subject: Re: [OpenIndiana-discuss] ZFS, Samba, Windows ACLs
Message-ID: <50798257.6050501 at cos.ru>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed

2012-10-13 1:51, lbragg at me.com wrote:
> I have used this site in the past
> (http://www.nineproductions.com/solaris-11-samba-zfs-configuration/)
> to configure a solaris server for Samba and windows ACLs and it worked
> pretty well.
> I am trying the same on OpenIndiana and cannot seem to get it to work.
> Are there any good tutorials out there for this? (I did google and could
> not find any)?
> Specifically the issues are with PAM, nsswitch, and setting the ACLs.
> -svccfg -s name-service/switch
> --svccfg: Pattern 'name-service/switch' doesn't match any instances or
> services
> Nsswitch does not seem to exist. (Remember I am new to this and it may
> be staring me in the face.)

First of all, this should be all with dashes (at least in OI):
# svccfg -s name-service-switch

Tried this and same issue, not found. I did try a `pkg search` but could not find the package.
Not sure what I am doing wrong... :/ 

Also there are name-services (when changing naming configs,
you often are better off restarting both of these).

> And,
> -chmod A- /tank1/Data
> --Try `chmod --help' for more information.
> So the chmod accepts options in a different manner. I read the help page
> but was still lost.

As others said, make sure to use /usr/bin/chmod.

/usr/bin/chmod was what I was looking for!

More information about the OpenIndiana-discuss mailing list