[OpenIndiana-discuss] ZFS remote receive

Gary Gendel gary at genashor.com
Tue Oct 23 12:32:33 UTC 2012

On 10/23/12 8:23 AM, Doug Hughes wrote:
> On 10/23/2012 7:52 AM, Sebastian Gabler wrote:
>> Hi,
>> I am facing a problem with zfs receive through ssh. As usually, root 
>> can't log on ssh; the log on users can't receive a zfs stream (rights 
>> problem), and pfexec is disabled on the target host (as I understand 
>> it is nowadays default for OI151_a...)
>> What are the suggestions to solve this? I tried several approaches 
>> with sudo, and su to no avail. I had tried to enable pfexec on the 
>> target system, too and couldn't do it.
> you can run it over any tcp transport. Do it yourself options include 
> using ttcp or netcat as a transport, but almost anything will do. It 
> requires a little bit more synchronization to do it this way since the 
> receiver must be running (piped into zfs recv) before the transmitter 
> is started or the transmitter will abort.
> In the end, though, you need to run the zfs recv as root somehow. If 
> that's the crux of the problem and not the inability to ssh as root, 
> you'll have to figure out a fix to get root at least for the zfs recv 
> process.
I had the same issue with rsync over ssh.  I finally decided to make 
root a user and restrict login access.

More information about the OpenIndiana-discuss mailing list