[OpenIndiana-discuss] ZFS remote receive

Geoff Nordli geoffn at gnaa.net
Tue Oct 23 17:59:50 UTC 2012

On 12-10-23 04:52 AM, Sebastian Gabler wrote:
> Hi,
> I am facing a problem with zfs receive through ssh. As usually, root 
> can't log on ssh; the log on users can't receive a zfs stream (rights 
> problem), and pfexec is disabled on the target host (as I understand 
> it is nowadays default for OI151_a...)
> What are the suggestions to solve this? I tried several approaches 
> with sudo, and su to no avail. I had tried to enable pfexec on the 
> target system, too and couldn't do it.
> Thanks for your help.
> BR
> Sebastian

Hi Sebastian.

I use the sudo method and I also assign the user zfs rights for that pool.
here is my sudoers file:

bkuser        ALL = NOPASSWD: /usr/sbin/zfs

and here is the rights assignment:

zfs allow -s @adminrole 
zfs allow bkuser @adminrole backup

I am sure it could be a lot tighter for security, but it works.

Have a great day!!


More information about the OpenIndiana-discuss mailing list