[OpenIndiana-discuss] 4k zpool version no longer available?

Jim Klimov jimklimov at cos.ru
Tue Sep 25 11:24:25 UTC 2012

2012-09-25 9:29, Jaco Schoonen wrote:
>> I tried after doing a "update_drv -f sd", but that gave an error:
>> # update_drv -f sd
>> Cannot unload module: sd
>> Will be unloaded upon reboot.
>> Forcing update of sd.conf.
>> Will try tomorrow after a reboot, can't do a reboot right now.
> Reboot doesn't change anything. zpool is still created with ashift=9

I saw in zfs-discuss that you've solved the problem by a "full reboot".
For posterity, a default reboot mode in OI is fast-reboot; and I am not
sure how much of the system is re-initialized in this case (there are
some things that only work after an initial boot or a full reset).

For such cases you might want to use "reboot -p" to kill the running OS
instance completely and reboot via "PROM" (BIOS on x86) including full
reinitialization of hardware.

//Jim Klimov

More information about the OpenIndiana-discuss mailing list