[OpenIndiana-discuss] 4k zpool version no longer available?

Richard Elling richard.elling at richardelling.com
Tue Sep 25 12:39:18 UTC 2012

On Sep 24, 2012, at 10:29 PM, Jaco Schoonen <jaco at macuser.nl> wrote:

>>>> After studying all the information about 4K-disks I figured out that to get more space in my server I need to create a new pool, consisting of 4K-disks and then moving everything from the old 512-byte pool to the new one. 
>>>> So far, so good. Everything is connected and detected correctly.  The 3TB Seagate drives that I bought unfortunately lie about their physical sector size, so I wanted to try the modified zpool as suggested in the wiki-page http://wiki.openindiana.org/pages/viewpage.action?pageId=4883847 . 
>>> A fix has been implemented upstream. See the details at 
>>> https://www.illumos.org/issues/2665
>> Reading there that this is included in illumos changeset 13680 and reading in release_notes of 151_a5 that oi151_a5 is based on 13740. Is my assumptions correct that this should work in oi151_a5?
>>> NB, VID/PID is matched by length, so "SEAGATE ST" will match all Seagate drives with
>>> product ID starting with "ST"
>>> 	sd-config-list = "SEAGATE ST", "physical-block-size:4096";
>> Just tried that, but can't get it to work. Do I need to reboot before this will work? 
>> I tried after doing a "update_drv -f sd", but that gave an error:
>> # update_drv -f sd
>> Cannot unload module: sd
>> Will be unloaded upon reboot.
>> Forcing update of sd.conf.
>> Will try tomorrow after a reboot, can't do a reboot right now.
> Reboot doesn't change anything. zpool is still created with ashift=9
> So either the usage of sd.conf is not in 151_a5, or the VID/PID are different from what you suggested above.
> How can I find or read out the VID/PID that the drive is reporting?

The format command will show VID/PID.

Did you check the boot messages in /var/adm/messages for clues?

Though not suitable for the casual admin, you can see the sd driver's assigned 
values by looking at the values with mdb:
	echo ::sd_state | mdb -k
and look for un_phy_blocksize

Some tools, like prtvtoc, predate the time when logical and physical block sizes
were different, so they only show the logical or physical sizes.
 -- richard

illumos Day & ZFS Day, Oct 1-2, 2012 San Fransisco 
Richard.Elling at RichardElling.com

More information about the OpenIndiana-discuss mailing list