[OpenIndiana-discuss] "Cannot read the pool label" error

Stefan Müller-Wilken stefan.mueller-wilken at acando.de
Sat Mar 8 22:52:21 UTC 2014

Dear all,

I tried to clone a server today using 'zpool send' / 'zpool receive'. I *think* I've done all necessary steps including install_grub - and have done that multiple times, just to make sure - but always end up with the following fatal error:

OpenIndiana Build oi_151a8 64-bit (illumos 7256a34efe)
SunOS Release 5.11 - Copyright 1983-2010 Oracle and/or its affiliates.
All rights reserved. Use is subject to license terms.
NOTICE: Cannot read the pool label from '/pci at 0,0/pci8086,25e3 at 3/pci103c,3235 at 0/sd at 0,0:a'
NOTICE: spa_import_rootpool: error 5
Cannot mount root on /pci at 0,0/pci8086,25e3 at 3/pci103c,3235 at 0/sd at 0,0:a fstype zfs

panic[cpu0]/thread=fffffffffbc2f400: vfs_mountroot: cannot mount root

Warning - stack not written to the dump buffer
fffffffffbc71ae0 genunix:vfs_mountroot+75 ()
fffffffffbc71b10 genunix:main+136 ()
fffffffffbc71b20 unix:_locore_start+90 ()

skipping system dump - no dump device configured

When booting from DVD, I can successfully import the rpool, I've also made sure to export it again but still no luck. Anything I'm missing here?


Acando GmbH, Millerntorplatz 1, 20359 Hamburg, Germany | Geschäftsführer: Guido Ahle | Amtsgericht Hamburg, HRB 76048 | Ust.Ident-Nr.:DE208833022

More information about the OpenIndiana-discuss mailing list