[OpenIndiana-discuss] "Cannot read the pool label" error

Udo Grabowski (IMK) udo.grabowski at kit.edu
Tue Mar 11 18:47:08 UTC 2014

On 08/03/2014 23:52, Stefan Müller-Wilken wrote:
> Dear all,
> I tried to clone a server today using 'zpool send' / 'zpool receive'. I *think* I've done all necessary steps including install_grub - and have done that multiple times, just to make sure - but always end up with the following fatal error:
> OpenIndiana Build oi_151a8 64-bit (illumos 7256a34efe)
> SunOS Release 5.11 - Copyright 1983-2010 Oracle and/or its affiliates.
> All rights reserved. Use is subject to license terms.
> NOTICE: Cannot read the pool label from '/pci at 0,0/pci8086,25e3 at 3/pci103c,3235 at 0/sd at 0,0:a'
> NOTICE: spa_import_rootpool: error 5
> Cannot mount root on /pci at 0,0/pci8086,25e3 at 3/pci103c,3235 at 0/sd at 0,0:a fstype zfs
> panic[cpu0]/thread=fffffffffbc2f400: vfs_mountroot: cannot mount root
> Warning - stack not written to the dump buffer
> fffffffffbc71ae0 genunix:vfs_mountroot+75 ()
> fffffffffbc71b10 genunix:main+136 ()
> fffffffffbc71b20 unix:_locore_start+90 ()
> skipping system dump - no dump device configured
> rebooting...
> When booting from DVD, I can successfully import the rpool, I've also made sure to export it again but still no luck. Anything I'm missing here?

You probably copied the devices from a host with a slightly
different architecture or device numbering. You must delete
the /dev/ and /devices/ directories and the /etc/path_to_inst
file and copy that from the new machine while booted from
a live-CD, see the relevant section in my original clone script:


# delete source machines devices and copy devs
# generated from live DVD below present devs
# This works over different hardware
mount -F lofs -o nosub / /mnt
rm -rf dev devices
(cd /mnt;tar cvf - devices dev)|tar xf -
umount /mnt
cp /etc/path_to_inst etc/

More information about the OpenIndiana-discuss mailing list