[OpenIndiana-discuss] Issues with libpcap

Dirk Oestreich djo at gmx.de
Sat Mar 17 23:39:17 UTC 2018


I noticed a bug in libpcap (1.8.1) with latest hipster and actual packages: "_eth_write(pcap): send: No such process".

To compile the emulator Simh (https://github.com/simh/simh) with pcap-networking-support I installed libpcap in OI. Then I created a vnic (promiscous mode, no IP set) and a bridge over the pysical nic. After that I compiled simh-vax, created the ini-file for NetBSD/vax, attached the vnic in it and installed NetBSD. In NetBSD when network was configured I tried to ssh from it to another host. Then the following error occured: "_eth_write(pcap): send: No such process".

I tested Simh also with OpenVMS/VAX and known working TCPIP-stack: booting up OpenVMS, login per telnet from another host to OpenVMS and executing "SHOW SYSTEM" - same error as above. Additionally the telnet connection crashes.
The error occurs on bare-metal-installation as well as in virtual machines - and there is no difference whether simh is running in the global-zone or in a non-global-zone (with ip-type exclusive).

In contrast, the same scenario is working flawlessly with latest OmniOSCE, Tribblix and also with precompiled Simh/pcap via pkgsrc under OI. Therefore I think the problem is with the OI-distributed libpcap-package.

Problems with other usecases for pcap besides working with Simh are beyond my knowledge, but maybe someone else got some trouble with it?



More information about the openindiana-discuss mailing list