[OpenIndiana-discuss] Kernel panic trying to install OI

Thorsten Heit thorsten.heit at vkb.de
Thu Oct 21 11:06:24 UTC 2010


some time ago I tried to upgrade from OpenSolaris b134 to OpenIndiana, but 
rebooting into OI always resulted in a kernel panic; see 

In another attempt today I booted the OI live USB image and tried 
installing OI directly onto one of the discs, but that was even less 
successful than upgrading: Kernel panic and a direct reboot when the 
installer was starting the installation process :-(

At the bottom of the window it showed "Preparing disk for OpenIndiana 
installation", hung a couple of seconds at 2%, and then... boom. I guess 
the installer tried to write the partition scheme to the physical medium 
when the reboot occurred. Writing obviously wasn't successful because I 
can still boot into the former installed OS.

I tried the same procedure by booting into OI with "-kv" as kernel 
parameter, but when the panic occurred the graphical screen was still 
shown on the monitor so I couldn't see on a text console what happened.

Don't know if it's the same reason, but trying to install Solaris 10 
9/2010 showed the same "feature": A reboot when the installation process 
started, i.e. tried to partition the disc and write data to it.

OSOL b134 doesn't show the above behaviour. There's no hang when it 
prepares the disk; instead it runs through it quite fast and starts 
copying data.

Any idea what's going on here? What can I do to get OI up and running?

My hardware:
- HP ProLiant ML350 G5
- 32GB RAM
- 2x Quad Core Xeon
- 3x160GB and 3x500 SATA discs connected to a SmartArray E200i controller
- NVidia Quadro NVS290 graphics card



More information about the OpenIndiana-discuss mailing list