[OpenIndiana-discuss] BTX halted

Priyadarshan oi at priyadarshan.com
Fri Mar 9 14:35:34 UTC 2018

On 2018-03-09 15:14, Bob Pasken wrote:

>> Hi,
>> I have successfully installed OpenIndiana Hipster 2017.10 Live via USB
>> image on a ThinkPad W541.
>> Now, I am trying to install to 2 different workstations, using same 
>> USB
>> stick:
>> - HP z620 with Xeon E5
>> - Asus X399 motherboard with AMD 1950X Threadripper
>> After a few seconds, both machines give same message "BTX halted"
>> See screehsots https://imgur.com/a/pXMKn
>> I tried setting BIOS to legacy mode and UEFI mode.
>> Right now both machines are running FReeBSD 11.1-RELEASE.
>>   From both, I am able to boot a FreeBSD installer, both in legacy 
>> mode
>> and UEFI mode.
>> I wonder why it boots fine from the ThinkPad, and not from the other 2
>> machines.
>> Is there anything I need to do in order to have the image boot?

> There are also problems with the FreeBSD bootloader on SunFire
> X4600's, Sun Ultra-40's and Sun Ultra-20's that are somewhat related.
> Toomas Soome has a fix, but it hasn't been put into OI yet

Hello Bob,

Thank you, your words are somehow consoling.

I have spent many hours yesterday and today, trying different methods, 
beside follwoing the instructions here: 

creating the USB stick using different OS: Win, OSX, Linux.

I even tried using UNetbootin, and "burning" the iso image to a USB 

Both machines do start the boot process. I can see the cursor spinning.

But, right after a few seconds, all methods fails with "BTX halted", as 
screenshots here: https://www.illumos.org/issues/9254

Thank you, I guess I will wait, hoping the FreeBSD bootloader will 
improve with next version of OpenIndiana.


More information about the openindiana-discuss mailing list